Safari Compatibility and Next App

If you run Safari and use the Class Schedule Maker you should see a dialog pop up with a warning about how certain features are not supported. All other modern browsers work just fine… I’ve spent hours trying to get Safari to work without luck. It does bother me, however, that the “standard” Mac browser can’t run the calculator correctly, and, after my next app is released (which will likely suffer from the same issue), I hope I can figure out some way around this problem.

Luckily the Safari issue is not app breaking: it just affects downloads, so you can’t export a schedule or save a schedule as an image. If all you’d like to do is make a schedule and print it out, everything should work great. Nonetheless, it bugs me that this issue exists at all!

Speaking of the next app, I think I’ve decided on what to build next. Unfortunately, I have a bad habit of changing direction all the time, so I’m going to keep the nature of it quiet until I’m near complete. It will, however, likely be a slightly more “complex” app like the schedule maker, which means it’ll take at least 3 weeks with my current job schedule.

 

SMALL UPDATE:

I made a small tweak on the college scheduler so that if you’re running Safari and try to export a schedule, it will bring up an error message. Not ideal but at least it fails a bit more gracefully now.